Image Build Error: Bad Request ("the Dockerfile (Dockerfile) cannot be empty")

Tried running a mission that used to run fine. My mission seems to have a docker file but got the following error. The same type of error occurs when I delete the docker file and try running the mission again.


Image Build Error

Error Description:
400 Client Error: Bad Request ("the Dockerfile (Dockerfile) cannot be empty")

Build Arguments:
{'container_limits': {},
 'forcerm': True,
 'path': '/tmp/galileo_zoz73tzd/5f8811ac-f57d-4a83-891e-ba835a26ddb6/build_context',
 'pull': True,
 'rm': True,
 'tag': '5f8811ac-f57d-4a83-891e-ba835a26ddb6'}

Hey @Derek, thanks for reaching out on the Forum! Can you try to open the Dockerfile for this project in the built-in text editor and see if it has any content in it?

@todd I’ve tried but I get the spinning wheel indefinitely. I have to reload the page to use the app again.

When I try to download it, I get

Something went wrong while downloading files.

When I try to delete it, I get

Cannot delete the dockerfile from a non-custom project!

Ah, so this error means that the Dockerfile is messed up for some reason. This is what’s keeping your project from running correctly. @Derek, if your input files aren’t very big, could you try to recreate the Mission again by rerunning the configuration wizard and reuploading the input files? If that’s not a realistic solution I have something else we can try.

No problem. I created another mission and it works now. In the future, it would be nice to figure out how I can still delete a file after it’s be corrupted, then in this case, all I would have to do is remove and rebuild the dockerfile.

Also, it would also be nice to have the option to copy an existing mission and have options to clone settings or files or both. I’ve run up to four similar jobs in parallel and ended up creating the same mission 4 times. Not a big deal for me since my missions are relatively small, but could be useful for future users with bigger missions!

Thanks!

I’m going to have to see what caused the Dockerfile to be messed up, I’ve also found one of my own projects that is throwing the same error as you. The reason you could not delete it is because the Dockerfile is a special file that is protected for security purposes.

Cloning an existing Mission is on the technical roadmap, it will definitely be a handy feature, and if you haven’t seen it yet, you can now invite collaborators to your mission and set their access permissions.

Ah, I see. Perhaps, there could be an option to force a rebuild of the docker file. Not sure if this is a corner case, but just a thought.

Its definitely a backend bug. I have one of our developers trying to hunt down how it happened.